發表文章

目前顯示的是 四月, 2013的文章

「教學」關於蘋果電腦 Mac OSX 上面的 Java 問題

這個問題從以前朋友問、家人問,同事問、到現在客人也問,說起來,實在是一個很不便民的問題,搞的只不過是瀏覽器上網,動不動就出現「Java 版本不適用,請去下載」之類的訊息,然後假如你真的去 Java 網站下載安裝了,會發現還是出現同樣的錯誤警告 ... 簡單的說,其實是 Mac OSX 上面使用了自家更改過後的 Java SE 6 系列版本,而 Java 網站上面下載的卻是 Java 7 系列的版本,所以 Safari 和 Google Chrome 就傻掉了。 所以若是想在 Safari 和 Google Chrome 上面比較正常的執行一些需要 Java 能力的網頁,依照 Apple 和 Java 兩家公司的建議是: 1. 移除(或暫停)Java 7 系列,請參照: http://www.java.com/zh_TW/download/help/mac_uninstall_java.xml 解除安裝 Oracle Java 7 依照列出的步驟進行,即可自系統解除安裝 Oracle Java 7。 注意:您必須要具備管理員權限才能夠解除安裝 Java 7。 1.按一下 Dock 中的 Finder 圖示 2.按一下側邊欄中的應用程式標籤 3.在「搜尋」方塊中輸入 JavaAppletPlugin.plugin 4.這樣會尋找 JavaAppletPlugin.plugin 檔案 5. 在 JavaAppletPlugin.plugin 上按一下滑鼠右鍵並選取丟到垃圾桶 2. 安裝最新的 Mac OSX Java SE 6 系列,請至 Apple 下載最新 Java 版本: http://support.apple.com/zh_HK/downloads/ 目前最新的是:Java for OS X 2013-003 http://support.apple.com/kb/DL1572 當你移除(或暫停)後,也安裝了最新的 OSX 使用的 Java 後,最好再手動做一下「重新啟用 Apple 提供的 Java SE 6 Web 外掛模組和 Web Start 功能」這檔事,以保心安。請參照: http://support.apple.com/kb/HT5559?viewlocale=zh_TW